Rebranding the Vitary

Incident Report for Vitary

Update

The Vitary will be renamed to Agni by April to June 2023
Posted Jan 30, 2023 - 09:33 UTC

Investigating

We are currently investigating this issue.
Posted Jan 30, 2023 - 09:32 UTC
This incident affects: General.